Contents

Release Notes for Version 1.1
5  •  New Features
5  •  Improvements / Changes
5  •  Fixes

Getting Started
6  •  Installing
6  •  Installing RBZ Package
6  •  Installing ZIP Package
7  •  Uninstalling
7  •  Activating / Deactivating

User Interface
8  •  Menus
8  •  Context Menus
8  •  Auto-Smooth
8  •  Show Normals
9  •  Lock UV Mapping
9  •  Toolbars
9  •  Vertex Mode Toolbar
9  •  SketchUp Toolbar
9  •  Information Panel
Tools

10 • Select
10 • Selection Shapes
11 • Soft Selection
11 • Ignore Backfaces
11 • Select Only Visible
12 • Manipulator Gizmo
12 • Move
12 • Rotate
12 • Scale
12 • Extrude Edges
12 • Alignment
13 • Orientation Lock
13 • Move
13 • Rotate
14 • Scale
14 • Insert
14 • Make Planar
14 • Merge Vertices
14 • Merge Close Vertices
SHORTCUTS
15 • Proxy Functions
15 • Available Proxy Functions
16 • Example

PREFERENCES
17 • Language
17 • Initial Tool
17 • Vertex Size
17 • Normal Size
17 • Context Menu
19 • .lang File Format Specification
20 • Tips and recommendations

KNOWN ISSUES / LIMITATIONS

KNOWN BUGS

CREDITS

CONTACT
Release Notes for Version 1.1

NEW FEATURES

- Manipulator Gizmo
- Extrude Edges
- Merge Vertices
- Merge Close Vertices
- Preserves UV mapping for triangles and quads.
- Select Only Visible

IMPROVEMENTS / CHANGES

- Added translation: Chinese Traditional.
- Added translation: Slovenian.
- Added translation: Portuguese.
- General performance improvements.
- Move tool accepts absolute and relative coordinates.
- Move tool automatically select vertex if nothing is pre-selected.
- Move and Rotate tool now merge entities.
- Ignore Backfaces now consider perpendicular faces to be visible.
- Makes auto-folded native quads compatible with QuadFace Tools.
- Erase Vertices merges co-linear edges.
- Make Planar now activates Vertex Mode if not already activated.
- Context menu can be toggled without restarting SketchUp.
- Removed special treatment of toolbar under Windows.
- Upgraded to jQuery 1.7.2 with IE9 support.

FIXES

- Vertices for hidden geometry is no longer displayed.
- Invert Selection now working outside Vertex Mode.
- Select All now working outside Vertex Mode.
- Delete key now functions under Windows.
- Vertex normals are more accurate.
- Move tool bug where preview was not displayed.
- Rotate tool protractor changed plane if cursor was moved quickly after first click.
- Set scrollable to false for config webdialog. Ensures no frame in SU8.
Installing RBZ Package
If you are using SketchUp 8 Maintenance Release 2 or newer, this is the preferred way to install Vertex Tools.

Download the RBZ package to your computer.
Open the Extension manager Window » Preferences » Extensions, click the Install Extension button and browse to the RBZ package. SketchUp will install and activate Vertex Tools.

Installing ZIP Package
If using an older version of SketchUp the plugin must be installed manually. Download the ZIP file to your computer and follow these instructions:

The zip file with Vertex Tools contains a file, `tt_vertex.rb` and a folder `TT_Vertex`. These should be extracted to SketchUp’s plugin folder. The location of this folder differs from platform to platform. On Windows it is in whatever folder SketchUp was installed to. On OSX it is at a fixed location.
Windows 32-bit: *(Default location for SketchUp 7)*
C:\Program Files\Google\Google SketchUp 7\Plugins\  

Windows 64-bit: *(Default location for SketchUp 7)*
C:\Program Files (x86)\Google\Google SketchUp 7\Plugins\  

OSX: *(SketchUp 7)*
/Library/Application Support/Google/Google SketchUp 7/SketchUp/plugins/  
For other SketchUp version replace the version number in the path.

---

Note OSX users: The path is under the root Library folder, not under your user folder!

The footprint of Vertex Tools in the Plugins folder is:
- 
  - 
  - 

    •  
    •  

If you run into problems installing ensure that the files are located in the correct location.

**UNINSTALLING**
Remove the file `tt_vertex.rb` and the folder `TT_Vertex` folder from where Vertex Tools was installed.

**ACTIVATING / DEACTIVATING**
Vertex Tools can be activated and deactivated via SketchUp’s extension manager. If you don’t see Vertex Tools in your Tools menu, ensure that the plugin is enabled under Window » Preferences » Extensions.
**User Interface**

**Menus**
Vertex Tools’ menus are located under SketchUp’s Tool menu. Vertex editing mode can be activated from its submenus. Edit Vertices and Preferences are the main items in the sub-menu. The other menus, such as Move, Rotate, Scale, etc. are there primarily to act as shortcut hooks so that SketchUp’s Shortcut manager can be used to assign shortcuts to the various functions. This is described in detail in the Shortcuts section.

**Context Menus**
While vertex editing a different context menu is available. It gives access to functions and preferences dependent on the active vertex editing tool. The context menu contains some items that are only accessible from the context menu:

**Auto-Smooth**
When a face is deformed in such a way that its vertices are no longer coplanar, SketchUp Auto folds the face by adding new edges. These edges are normally not soft or smooth which as a result produce a faceted surface.

When Auto-Smooth is enabled these new edges will be softened and smoothed ensuring a continuous surface.

**Show Normals**
Turn this on for visual clue representing the normals for the surfaces connected to the vertex. The normals point in the same direction as the front side of the connected faces.
**Lock UV Mapping**
When enabled it will lock the UV mapping of textured faces when manipulated. This works best on quads and triangles.

**TOOLBARS**

**Vertex Mode Toolbar**
Vertex Tools’ main toolbar appears only when vertex editing mode is activated. It is drawn directly onto SketchUp’s viewport and because of that it does not behave exactly like the normal toolbars in SketchUp.

- It cannot float over other windows.
- It cannot move outside SketchUp’s viewport.

**SketchUp Toolbar**
A normal SketchUp toolbar is available that provides a single button to activate vertex mode. This toolbar is by default not visible.

Available from: View » Toolbars » Vertex Tools

**INFORMATION PANEL**
The information panel floats on the screen while editing vertices displaying vertex statistics of the current selection. It can be moved around by clicking and dragging within the dotted frame that appear when the mouse is over it.
Tools

The tools available to modify vertices tries to mirror SketchUp’s native tools as closely as possible. Where new tools are introduced without a native counterpart their behaviour tries to keep with normal SketchUp conventions.

Known Issue: Due to limitation of SketchUp 6, local axes is not correct, instead only world axis is used.

SELECT

Also accessible via Tools » Vertex Tools » Select

Activates the last used selection shape tool. Normal selection modifies applies to all selection shapes:

- Adding to selection: Press and hold Ctrl (Microsoft Windows) or Options (OS X).
- Toggle selection status: Press and hold Shift.
- Remove from selection: Press and hold Ctrl and Shift (Microsoft Windows) or Option (OS X).

When a selection tool is active a second row of buttons becomes available.

Selection Shapes

- Rectangular Select – Press and hold down the left mouse button to create a rectangular selection area or click a vertex to add individual vertices.
- Circular Select – Press and hold down the left mouse button to create a circular selection area or click a vertex to add individual vertices.
- Polygon Select – Click to add points to polygon selection. Double click to finish polygon.
- Freehand Select – Press and hold down the left mouse button while moving the cursor to create a freehand selection shape.
**Soft Selection**

Soft Selection is set by typing in a Length in the VCB while a selection tool is active. Vertices within this distance from the selected vertices are also affected by tools that modify the geometry. The further away from the selection, the less they are affected. This is illustrated by colour-coding the vertices from Red, Orange, Yellow, Green and Blue – where Red is 100% and Blue is 0%. There are two types of fall-off for the soft-selection radius:

- **Linear fall-off**
  - Linear falloff affects the vertices directly proportional to their distance from the selected.
- **Cosine fall-off**
  - Cosine falloff affects the vertices using a cosine curve.

**Ignore Backfaces**

Turn this on to prevent selecting vertices attached to faces pointing away from the camera. Faces perpendicular to the camera is considered visible.

---

Note that this is not the same as selecting only visible vertices. Vertices connected to faces pointing towards the camera but obscured by other objects will still be selected.

---

**Select Only Visible**

Accessible via Tools » Vertex Tools » Select Only Visible

Also accessible via Context Menu » Select Only Visible

Use this function if you want to filter out only the selected vertices that is visible to the camera. It is a slow function that might take a while if you have many vertices in your selection.
MANIPULATOR GIZMO

The Gizmo allows for quick manipulations without switching out of selection mode. All its actions can be adjusted by the VCB for final precision adjustments. After you made an action with the Gizmo you can revert to controlling the soft-selection with the VCB by pressing **ESC**.

**Move**
Press and hold down the left mouse button on one of the arrows to move it in the direction of the picked axis.

**Rotate**
Press and hold down the left mouse button on one of the rotation arcs. The rotation you can do in the viewport ranges from -180 to 180 degrees. To rotate beyond this range use the VCB to adjust.

**Scale**
Press and hold down the left mouse button on one of the scaling axes. Hold down **Shift** to perform a 3-dimensional scaling.

**Extrude Edges**
While interacting with the Move handles, hold down **Ctrl** (Microsoft Windows) or **Options** (OS X) to extrude faces from your selection. The faces are created from the edges between the selected vertices.

**Alignment**
From the Context Menu you can adjust the alignment of the Gizmo. By default it aligns to the local axis - be it custom model axis or the active context. From the Context Menu you can pick other options:

**View**
The Gizmo will always align the Z axis (blue) to the direction of the camera.
**World**
The Gizmo will align to the absolute world axis - the one you get when you are in the root context and reset the axis.

**Local**
The Gizmo will align to the current model axis or the open group/component’s local axis.

**Custom**
Align the Gizmo by picking points in 3D space. You can also pick orientation by holding Shift and picking a face or edge.

**Orientation Lock**
When enabled the gizmo will retain its orientation when you rotate. When disabled the gizmo will move with the rotation actions you perform.

**MOVE**

Also accessible via Tools » Vertex Tools » Move

1. Pick a point for the origin of the move.
2. Move the cursor to move the selected vertices. The distance is displayed in the VCB.
3. To complete the move, either click a second time or enter a distance in the VCB for an accurate displacement.

Inference and axis lock is available for the Move tool. After completing a Move operation the distance can be corrected by typing a length in the VCB immediately afterwards.

Absolute and relative coordinates can be entered instead of a length. Use the same format the native Move tool uses - with \([x, y, z]\) for global coordinates and \(<x, y, z>\) for local coordinates.

If nothing is preselected before activating the Move tool it will automatically select the vertices you hover over. This allows you to quickly pick and move vertices with precision.

**ROTATE**

Also accessible via Tools » Vertex Tools » Rotate

1. Pick a point for the origin of the rotation. Like the native rotate tool you can infer and lock the plane of rotation by pressing and holding Shift before placing the first point. The same goes for the click-drag method of defining the rotation plane.
2. Pick a second point to define a reference axis.
3. Move the cursor to rotate. The angle is displayed in the VCB.
4. To complete the rotation, either click a third time or enter an angle in the VCB for accurate rotation.

After completing a rotation the angle can be adjusted by typing a new angle in the VCB.

If ‘Enable angle snapping’ is checked in the Units Panel of the Model Info dialogue window, the protractor will snap to the specified angle — just like the native Rotate tool.
SCALE
Also accessible via Tools » Vertex Tools » Scale

1. Pick the centre point to scale about or type a scale ratio into the VCB. If the VCB is used the centre point of the selection is used as the point to scale about.
2. Pick a second point to define a reference length.
3. Move the cursor to scale. The scale is displayed in the VCB.
4. To complete the scaling, click a third time or enter a scale ratio.

After completing a scale operation the ratio can be adjusted by typing a new value into the VCB.

INSERT
Also accessible via Tools » Vertex Tools » Insert Vertex

1. Pick a point on an Edge or a Face.

Edges are split at the point picked.
When the point picked is on a Face, new edges are created from each vertex of the Face towards the point provided they do not cross any existing edges. Press Ctrl to toggle between soft & smooth versus hard edges.

The tool makes use of snapping inference, but no inference locking.

MAKE PLANAR
Also accessible via Tools » Vertex Tools » Make Planar
Selected vertices will be projected to a best fitting plane.
Soft selected vertices are affected but do not contribute to the computation of the plane.

MERGE VERTICES
Also accessible via Tools » Vertex Tools » Merge Vertices
Collapses the selection into a single point which is the average position of the selection.

MERGE CLOSE VERTICES
Accessible via Tools » Vertex Tools » Merge Close Vertices
Also accessible via Context Menu » Merge Close Vertices
Collapses vertices that is within the given range of each other to a single point.
Shortcuts

Shortcuts to Vertex Tools’ functions are assigned using SketchUp shortcut manager – Window » Preferences » Shortcuts.

To quickly locate Vertex Tool’s functions use the Filter box above the function list.

PROXY FUNCTIONS

Some of Vertex Tools’ menus have double functions. Using Tools » Vertex Tools » Move as an example:

• When vertex mode is active this trigger Vertex Tools’ Move tool.
• When not editing vertices this trigger SketchUp’s native Move tool.

This allows user to have their shortcuts functioning inside and outside vertex mode because the menus act as proxies that knows which tool to activate.

Available Proxy Functions

• Select (All select variant will trigger the native select tool when outside vertex mode)
• Move
• Rotate
• Scale
• Select All
• Select None
• Invert Selection
**Example**

If any of Vertex Tools’ menus for Select is activated while a vertex select tools is already active it will exit vertex mode:

1. Space has been assigned to Vertex Tools » Select:
2. Vertex mode is active; the Move tool is the active tool.
3. The user presses Space, the Vertex Select tool is activated.
4. The user presses Space a second time, vertex mode is ended and SketchUp’s native Select tools become active.

______________________________

Limitations: The Delete key can’t be remapped in SketchUp. This is a SketchUp limitation.

______________________________

Note: When changing the language of Vertex Tools any shortcuts must be reassigned. This is because SketchUp use the menu text to identify the correct function to trigger.

______________________________

Note: If shortcuts are assigned to Vertex Tools’ functions and Vertex Tools is uninstalled, the shortcuts must be manually mapped back to their original functions. SketchUp will not do this automatically.
Preferences
Accessible via Tools » Vertex Tools » Preferences

Language
List of available languages for Vertex Tools. SketchUp must be restarted for the new language to take effect.

Note: If shortcuts has been assigned to Vertex Tools’ functions they must be remapped after changing language.

Initial Tool
By default Vertex Tools will start with the last used vertex tool when entering vertex mode. This can be overridden here to always select a specific tool.

Vertex Size
This value affects the visual size and clickable area of a vertex. The value must be between 4 and 10.

Normal Size
Vertex normals indicate the direction of the faces connected to each vertex. Faces connected by a soft edge will share a normal indicator averaging the normals of the faces.

Context Menu
Enable this to add a “Edit Vertices” menu item in SketchUp’s context menu to activate vertex mode.
Translations

Vertex Tools can be translated into different languages by creating simple .lang files located in the Localisation folder.

Use the Norwegian language file (no-nb.lang) as a template when translating as it will always be updated and contain all the strings available. Additionally it includes comments with hints and a description of the file format.
.LANG FILE FORMAT SPECIFICATION

I. File MUST be plain text UTF-8 encoded. BOM is supported. If any .lang file is not UTF-8 encoded strange characters will appear and it can affect all other translations. Refer to your chosen text editor for how to encode files in UTF-8.

II. The filename MUST be saved with ASCII range characters. SketchUp’s Ruby version (1.8) does not handle files with non-ASCII characters.

III. Please name your .lang file using the language code SketchUp reports for that language. This will ensure that Vertex Tools tries to load the language which matches the current SketchUp language. A list of language codes can be found here:
http://download.sketchup.com/OnlineDoc/gsu6_ruby/Docs/ruby-sketchup.html#get_locale
Example for French language file: “fr.lang”
If you can’t find the language listed, just use any name as long as it does not conflict with any of the language codes on the list.

IV. @title MUST be the first line in the file. This is a special tag that contains the name of the language which appears in the list of available Languages under Preferences. The title should be the name of the language in its native language – not English.

V. @author and @contact are two optional tags that MUST appear right after the @title tag in any order. This is the credit and contact information that appear under the chosen language under Preferences.

VI. @contact tag MUST start with “http://”, “https://” or “mailto:”.

VII. Except the header tags the content of the file can be in any order.

VIII. After the header tags comments can be added by prefixing the line with #.

IX. The % symbol is a special character. It represents a variable and MUST be included. If you need to add a percent symbol to the strings you can do so by using a double percent sign: %%
Example: “Hello %% World” becomes “Hello % World”
All the strings are sprintf formatted.
For more info: http://ruby-doc.org/core/classes/Kernel.html#M005962

X. Another set of variables are @@n - where n represent a number. These are used by webdialogs. When present in the original string they MUST appear in the translated string. Example: “Hello @@1 World” becomes “Hello 123 World”
XI. Do not insert line breaks. The strings must appear on a single line.

TIPS AND RECOMMENDATIONS

Please include your name, contact info and the date the file was last revised.

To check for missing strings you can open the Ruby Console and type **TT_Vertex::S.check** This will compare all the language files against the Norwegian file and list any missing strings for all the languages.

Do not literally translate the words, translate the meaning.

If possible, use the same terms used in SketchUp if SketchUp exist in the target language. Look at other 3d modelling and graphic software products to figure out what the norm is.


Look for guidance for translating to your own language. Often you can find guides provided by Open Source projects.

**Known Issues / Limitations**

- SketchUp 6 does not recognize user defined model axis.

**Known Bugs**

- Insert Vertex occasionally creates new faces when there are holes in the face. Investigating.
- Rotation Gizmo’s guide line does not always appear as an infinite line. Investigating.
Credits
Thanks to all the beta testers that provided invaluable feedback and support.
Thanks to the translators who contributed translations and interesting semantic discussions.
Thanks to Sketchucation for the support during the development.
Thanks to Google for letting me use some of SketchUp’s cursors and toolbar icons.
Big thanks to TBD and AdamB for helping me get started with Ruby C Extensions when I needed to crunch numbers in a speedy manner.

Contact
Use the contact form at Vertex Tools’ website for any questions or feedback.
http://www.thomthom.net/software/vertex_tools/contact
I can also be found lingering around the forums at Sketchucation.