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G e t t i n g  S t a r t e d
Installin g
The zip file with Vertex Tools contains a file, tt_vertex.rb and a folder TT_Vertex. These should be extracted to 
SketchUp’s plugin folder. The location of this folder differs from platform to platform. On Windows it is in whatever folder 
SketchUp was installed to. On OSX it is at a fixed location. 

Windows 32-bit: (Default location for SketchUp 7)
C:\Program Files\Google\Google SketchUp 7\Plugins\

Windows 64-bit: (Default location for SketchUp 7)
C:\Program Files (x86)\Google\Google SketchUp 7\Plugins\

OSX:  (SketchUp 7)
/Library/Application Support/Google/Google SketchUp 7/SketchUp/plugins/

For other SketchUp version replace the version number in the path.

Note OSX users: The path is under the root Library folder, not under your user folder!

The footprint of Vertex Tools in the Plugins folder is:
•	 [..]/Google SketchUp 7/SketchUp/plugins/TT_Vertex/

•	 [..]/Google SketchUp 7/SketchUp/plugins/tt_vertex.rb

If you run into problems installing ensure that the files are located in the correct location.

Uninstallin g
Remove the file tt_vertex.rb and the folder 
TT_Vertex folder from where Vertex Tools was 
installed.

Activatin g /  Deactivatin g
Vertex Tools can be activated and deactivated via 
SketchUp’s extension manager. If you don't see Ver-
tex Tools in your Tools menu, ensure that the plugin is 
enabled under Window » Preferences » Extensions.
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Use r  I n t e r f ac e
Menus
Vertex Tools’ menus are located under SketchUp’s Tool menu. Vertex editing mode can 
be activated from its submenus. Edit Vertices and Preferences are the main items in the 
sub-menu. The other menus, such as Move, Rotate, Scale, etc. are there primarily to 
act as shortcut hooks so that SketchUp’s Shortcut manager can be used to assign short-
cuts to the various functions. This is described in detail in the Shortcuts section.

Context  Menus
While vertex editing a different context menu is available. It gives access to functions 
and preferences dependent on the active vertex editing tool. The context menu contains 
some items that are only accessible from the context menu:

Auto-Smooth
When a face is deformed in such a way that its vertices are no longer coplanar, Sketchup Autofolds the face by adding new 
edges. These edges are normally not soft or smooth which as a result produce a faceted surface.

When Auto-Smooth is enabled these new edges will be softened and smoothed ensuring a continuous surface.
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Show Normals
Turn this on for visual clue representing the normals for the surfaces connected 
to the vertex. The normals point in the same direction as the front side of the 
connected faces.

Toolbars

Vertex Mode Toolbar
Vertex Tools’ main toolbar appears only when vertex editing mode is activat-
ed. It is drawn directly onto SketchUp’s viewport and because of that it does 
not behave exactly like the normal toolbars in SketchUp. 

•	 It cannot float over other windows.
•	 It cannot move outside SketchUp’s viewport.

SketchUp Toolbar
A normal SketchUp toolbar is available that provides a single button to activate vertex mode. This toolbar is by 
default not visible. Due to SketchUp’s tendencies under Windows to shuffle toolbars around the procedure to en-

able it is different than the OSX version.
OSX: View » Toolbars » Vertex Tools
Windows: Tools » Vertex Tools » Preferences – Toolbar

Information Panel
The information panel floats on the screen while editing vertices displaying vertex 
statistics of the current selection. It can be moved around by clicking and dragging 
within the dotted frame that appear when the mouse is over it.
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Too l s
The tools available to modify vertices tries to mirror SketchUp’s native tools as closely as possible. Where new tools are 
introduced without a native counterpart their behaviour tries to keep with normal SketchUp conventions.

Known Issue: Due to limitation of SketchUp 6, inferences cannot correctly lock to user defined axis when the 
user presses the arrow keys.

Select
Also accessible via Tools » Vertex Tools » Select
Activates the last used selection shape tool. Normal selection modifies applies to all selection shapes:

•	 Adding to selection: Press and hold Ctrl (Microsoft Windows) or Options (OS X).
•	 Toggle selection status: Press and hold Shift.
•	 Remove from selection: Press and hold Ctrl and Shift (Microsoft Windows) or Option (OS X).

When a selection tool is active a second row of buttons becomes available.

Selection Shapes
Rectangular Select – Press and hold down the left mouse button to create a rectangular selection area or click a vertex 

to add individual vertices.
Circular Select – Press and hold down the left mouse button to create a circular selection area or click a vertex to add 

individual vertices.
Polygon Select – Click to add points to polygon selection. Double click to finish polygon.
Freehand Select – Press and hold down the left mouse button while moving the cursor to create a freehand selection 

shape.
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Soft Selection
Soft Selection is set by typing in a Length in the VCB 
while a selection tool is active. Vertices within this dis-
tance from the selected vertices are also affected by 
tools that modify the geometry. The further away from 
the selection, the less they are affected. This is illustrated 
by colour-coding the vertices from Red, Orange, Yellow, 
Green and Blue – where Red is 100% and Blue is 0%.
There are two types of fall-off for the soft-selction radius:

Linear fall-off Cosine fall-off

Linear falloff affects the vertices directly proportional to their distance from the selected. Cosine falloff affects the vertices 
using a cosine curve.

Ignore Backfaces
Turn this on to prevent selecting vertices attached to faces pointing away from the camera.

Note that this is not the same as selecting only visible vertices. Vertices connected to faces pointing towards 
the camera but obscured by other objects will still be selected.

Move
 Also accessible via Tools » Vertex Tools » Move
1.	 Pick a point for the origin of the move.

2.	 Move the cursor to move the selected vertices. The distance is displayed in the VCB.
3.	 To complete the move, either click a second time or enter a distance in the VCB for an accurate displacement.

Inference and axis lock is available for the Move tool. After completing a Move operation the distance can be corrected by 
typing a length in the VCB immediately afterwards. 
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Rotate
 Also accessible via Tools » Vertex Tools » Rotate
1.	 Pick a point for the origin of the rotation. Like the native rotate tool you can infer and lock the plane of rotation by 

pressing and holding Shift before placing the first point. The same goes for the click-drag method of defining the rotation 
plane.
2.	 Pick a second point to define a reference axis.
3.	 Move the cursor to rotate. The angle is displayed in the VCB.
4.	 To complete the rotation, either click a third time or enter an angle in the VCB for accurate rotation.

After completing a rotation the angle can be adjusted by typing a new angle in the VCB.
If ‘Enable angle snapping’ is checked in the Units Panel of the Model Info dialogue window, the protractor will snap to the 
specified angle — just like the native Rotate tool.

Scale
 Also accessible via Tools » Vertex Tools » Scale
1.	 Pick the centre point to scale about or type a scale ratio into the VCB. If the VCB is used the centre point of the 

selection is used as the point to scale about.
2.	 Pick a second point to define a reference length.
3.	 Move the cursor to scale. The scale is displayed in the VCB.
4.	 To complete the scaling, click a third time or enter a scale ratio.

After completing a scale operation the ratio can be adjusted by typing a new value into the VCB.

Insert
 Also accessible via Tools » Vertex Tools » Insert Vertex
1.	 Pick a point on an Edge or a Face.

Edges are split at the point picked.
When the point picked is on a Face, new edges are created from each 
vertex of the Face towards the point provided they do not cross any existing 
edges. Press Ctrl to toggle between soft & smooth versus hard edges.
The tool makes use of snapping inference, but no inference locking.

Make  Planar
 Also accessible via Tools » Vertex Tools » Make Planar
Selected vertices will be projected to a best fitting plane. 

Soft selected vertices are affected but do not contribute to the 
computation of the plane.
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Shor t c u t s
Shortcuts to Vertex Tools’ functions are assigned using SketchUp shortcut manager – Window » Preferences » Shortcuts.

To quickly locate Vertex Tool’s functions use the Filter box above the function list.

Proxy Functions
Some of Vertex Tools' menus have double functions. Using Tools » Vertex Tools » Move as an example:

•	 When vertex mode is active this trigger Vertex Tools’ Move tool.
•	 When not editing vertices this trigger SketchUp’s native Move tool.

This allows user to have their shortcuts functioning inside and outside vertex mode because the menus act as proxies that 
knows which tool to activate.

Available Proxy Functions
•	 Select (All select variant will trigger the native select tool when outside vertex mode)
•	 Move
•	 Rotate
•	 Scale
•	 Select All
•	 Select None
•	 Invert Selection
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Example
If any of Vertex Tools’ menus for Select is activated while a vertex select tools is already active it will exit vertex mode:

1.	 Space has been assigned to Vertex Tools » Select:
2.	 Vertex mode is active; the Move tool is the active tool.
3.	 The user presses Space, the Vertex Select tool is activated.
4.	 The user presses Space a second time, vertex mode is ended and SketchUp’s native Select tools become active.

Limitations: The Delete key can’t be remapped in SketchUp. This is a SketchUp limitation.

Note: When changing the language of Vertex Tools any shortcuts must be reassigned. This is because 
SketchUp use the menu text to identify the correct function to trigger.

Note: If shortcuts are assigned to Vertex Tools’ functions and Vertex Tools is uninstalled, the shortcuts must be 
manually mapped back to their original functions. SketchUp will not do this automatically.
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Pr e f e r e n c e s
Accessible via Tools » Vertex Tools » Preferences

Language
List of available languages for Vertex Tools. SketchUp must be restarted for 
the new language to take effect.

Note: If shortcuts has been assigned to Vertex Tools’ functions they 
must be remapped after changing language.

Initial    Tool
By default Vertex Tools will start with the last used vertex tool when entering vertex mode. This can be overridden here to 
always select a specific tool.

Vertex S ize
This value affects the visual size and clickable area of a vertex. The 
value must be between 4 and 10.

Normal  S ize
Vertex normals indicate the direction of the faces connected to each 
vertex. Faces connected by a soft edge will share a normal indicator 
averaging the normals of the faces.
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Toolbar
The purpose for this setting is mainly for PC users. It is a work around for the Windows version of SketchUp which has an 
unfortunate tendency to shuffle about the user’s toolbars whenever a plugin with a toolbar is added. Because of this the 
Vertex Tools’ toolbar is not available from View » Toolbars by default under Windows. The toolbar must be enabled through 
this setting before it becomes available. 

Note that it will still cause SketchUp to shuffle about the toolbars, but it gives users that do not wish to use the 
toolbar an option to avoid being affected.

OSX users do not have to use this preference as the toolbar will be available from View » Toolbars by de-
fault.

Context  Menu
Enable this to add a "Edit Vertices"menu item in SketchUp’s context menu to activate vertex mode.

Tr an s l a t i on s
Vertex Tools can be translated into different languages by creating simple .lang files located in the Localisation 
folder.

Use the Norwegian language file (no-nb.lang) as a template when translating as it will always be updated and contain 
all the strings available. Additionally it includes comments with hints and a description of the file format. 
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. lang F il e  Format  Specification 
I.	 File MUST be plain text UTF-8 encoded. BOM is supported. If any .lang file is not UTF-8 encoded strange char-

acters will appear and it can affect all other translations. Refer to your chosen text editor for how to encode files 
in UTF-8.

II.	 The filename MUST be saved with ASCII range characters. SketchUp’s Ruby version (1.8) does not handle files 
with non-ASCII characters.

III.	 Please name your .lang file using the language code SketchUp reports for that language. This will ensure that 
Vertex Tools tries to load the language which matches the current SketchUp language. A list of language codes 
can be found here: 
http://download.sketchup.com/OnlineDoc/gsu6_ruby/Docs/ruby-sketchup.html#get_locale 
Example for French language file: “fr.lang”
If you can’t find the language listed, just use any name as long as it does not conflict with any of the language 
codes on the list.

IV.	 @title MUST be the first line in the file. This is a special tag that contains the name of the language which ap-
pears in the list of available Languages under Preferences. The title should be the name of the language in its 
native language – not English.

V.	 @author and @contact are two optional tags that MUST appear right after the @title tag in any order. This 
is the credit and contact information that appear under the chosen language under Preferences.

VI.	 @contact tag MUST start with “http://”, “https://” or “mailto:”.

VII.	 Except the header tags the content of the file can be in any order.

VIII.	 After the header tags comments can be added by prefixing the line with #.

IX.	 The % symbol is a special character. It represents a variable and MUST be included. If you need to add a percent 
symbol to the strings you can do so by using a double percent sign: %%
Example: “Hello %% World” becomes “Hello % World”
All the strings are sprintf formatted.
For more info: http://ruby-doc.org/core/classes/Kernel.html#M005962

X.	 Another set of variables are @@n - where n represent a number. These are used by webdialogs. When present 
in the original string they MUST appear in the translated string. Example: “Hello @@1 World” becomes 
“Hello 123 World”
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XI.	 Do not insert line breaks. The strings must appear on a single line.

T ips and r ecommendations
Please include your name, contact info and the date the file was last revised.
To check for missing string you can open the Ruby Console and type TT_Vertex::S.check This will compare all the 
language files against the Norwegian file and list any missing strings for all the languages.
Do not literally translate the words, translate the meaning.
If possible, use the same terms used in SketchUp if SketchUp exist in the target language. Look at other 3d modelling and 
graphic software products to figure out what the norm is.
Great repository of translations terms in Microsoft’s products: http://msdn.microsoft.com/en-gb/goglobal/bb688105.aspx
Look for guidance for translating to your own language. Often you can find guides provided by Open Source projects. 

Known  I s s u e s  /  L i m i ta t i on s
•	 No way to hook into the use of the Delete key. SketchUp limitation.
•	 SketchUp 6 does not recognize user defined model axis.
•	 Rotation tool might rotate the rotation plane if the user moves the cursor too quickly after placing the initial reference 
point. Deviation from the native Rotate tool. Investigating.
•	 VCB is always enabled, even for tools that do not accept input. Technical limitation.

Known  Bugs
•	 Insert Vertex occasionally creates new faces when there are holes in the face. Investigating.
•	 Rotation Gizmo’s guide line does not always appear as an infinite line. Investigating.

http://msdn.microsoft.com/en-gb/goglobal/bb688105.aspx
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C r e d i t s
Thanks to all the beta testers that provided invaluable feedback and support.
Thanks to the translators who contributed translations and interesting semantic discussions.
Thanks to Sketchucation for the support during the development.
Thanks to Google for letting me use some of SketchUp’s cursors and toolbar icons.
Big thanks to TBD and AdamB for helping me get started with Ruby C Extensions when I needed to crunch numbers in a 
speedy manner.

Con tac t
Use the contact form at Vertex Tools’ website for any questions or feedback.
http://www.thomthom.net/software/vertex_tools/contact
I can also be found lingering around the forums at Sketchucation.

http://www.sketchucation.com/
http://plugins.ro/
http://www.light-up.co.uk/
http://www.thomthom.net/software/vertex_tools/contact
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