Shortcuts

Shortcuts to Vertex Tools’ functions are assigned using SketchUp shortcut manager – Window » Preferences » Shortcuts.

To quickly locate Vertex Tool’s functions use the Filter box above the function list.

Proxy Functions

Some of Vertex Tools' menus have double functions. Using Tools » Vertex Tools » Move as an example:

  • When vertex mode is active this trigger Vertex Tools’ Move tool.
  • When not editing vertices this trigger SketchUp’s native Move tool.

This allows user to have their shortcuts functioning inside and outside vertex mode because the menus act as proxies that knows which tool to activate.

Available Proxy Functions

  • Select (All select variant will trigger the native select tool when outside vertex mode)
  • Move
  • Rotate
  • Scale
  • Select All
  • Select None
  • Invert Selection

Example

If any of Vertex Tools’ menus for Select is activated while a vertex select tools is already active it will exit vertex mode:

  1. Space has been assigned to Vertex Tools » Select:
  2. Vertex mode is active; the Move tool is the active tool.
  3. The user presses Space, the Vertex Select tool is activated.
  4. The user presses Space a second time, vertex mode is ended and SketchUp’s native Select tools become active.

Limitations: The Delete key can’t be remapped in SketchUp. This is a SketchUp limitation.

Note: When changing the language of Vertex Tools any shortcuts must be reassigned. This is because SketchUp use the menu text to identify the correct function to trigger.

Note: If shortcuts are assigned to Vertex Tools’ functions and Vertex Tools is uninstalled, the shortcuts must be manually mapped back to their original functions. SketchUp will not do this automatically.