Getting Started

Installing

RBZ Package

If you are using SketchUp 8 Maintenance Release 2 or newer, this is the preferred way to install Vertex Tools.

Download the RBZ package to your computer.

Open the Extension manager Window » Preferences » Extensions, click the Install Extension button and browse to the RBZ package. SketchUp will install and activate Vertex Tools.

SketchUp Help - Installing Ruby Plugins

ZIP Package

If using an older version of SketchUp the plugin must be installed manually. Download the ZIP file to your computer and follow these instructions:

The zip file with Vertex Tools contains a file, tt_vertex.rb and a folder TT_Vertex. These should be extracted to SketchUp’s plugin folder. The location of this folder differs from platform to platform. On Windows it is in whatever folder SketchUp was installed to. On OSX it is at a fixed location.

Windows 32-bit: (Default location for SketchUp 7)
C:\Program Files\Google\Google SketchUp 7\Plugins\
Windows 64-bit: (Default location for SketchUp 7)
C:\Program Files (x86)\Google\Google SketchUp 7\Plugins\
OSX: (SketchUp 7)
/Library/Application Support/Google/Google SketchUp 7/SketchUp/plugins/

Note OSX users: The path is under the root Library folder, not under your user folder!

The footprint of Vertex Tools in the Plugins folder is:

  • […]/Google SketchUp 7/SketchUp/plugins/TT_Vertex/
  • […]/Google SketchUp 7/SketchUp/plugins/tt_vertex.rb

If you run into problems installing ensure that the files are located in the correct location.

Uninstalling

Remove the file tt_vertex.rb and the folder TT_Vertex folder from where Vertex Tools was installed.

Activating / Deactivating

Vertex Tools can be activated and deactivated via SketchUp’s extension manager. If you don't see Vertex Tools in your Tools menu, ensure that the plugin is enabled under Window » Preferences » Extensions.